您的位置:首页 > 移动开发 > IOS开发

HDU 1017.A Mathematical Curiosity【细节及转换】【8月18】

2015-08-18 19:09 393 查看
A Mathematical Curiosity

Problem Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input

1

10 1
20 3
30 4
0 0


Sample Output

Case 1: 2
Case 2: 4
Case 3: 5


注意格式!!!给定n,m。问满足0 < a < b < n and (a^2+b^2 +m)/(ab) 的(a,b)点有多少组。水水更健康···············代码如下:

#include<cstdio>
int main(){
int N;
scanf("%d",&N);
for(int k=0;k<N;k++){
if(k!=0) printf("\n");//控制格式
int kase=0,n,m;
while(scanf("%d%d",&n,&m)&&m+n){
int sum=0;
for(int i=1;i<n-1;i++)
for(int j=i+1;j<n;j++)
if((double)(i*i+j*j+m)/(i*j)==(i*i+j*j+m)/(i*j))//直接判断是不是整数
sum++;
printf("Case %d: %d\n",++kase,sum);
}
}
return 0;
}
一个小细节: 判断是不是整数还可以这么判断 (i*i+j*j+m)%(i*j)==0 则为整数。




内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: