您的位置:首页 > 产品设计 > UI/UE

POJ 1503 Integer Inquiry 高精度

2015-08-15 19:09 316 查看
A - Integer Inquiry
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d
& %I64u
SubmitStatus

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0


Sample Output

370370367037037036703703703670
ACcode:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define maxn 1000
using namespace std;
char a[maxn];
int ans[maxn*2]={};
int t,len;
void fun(){
    int t=0;
    while(a[t]=='0')t++;
    len=strlen(a);
    ans[0]=max(ans[0],len-t);
    for(int i=1;i<=len-t;++i){
        ans[i]+=(a[len-i]-'0');
    }
    for(int i=1;i<ans[0];++i){
        if(ans[i]>9){
            ans[i+1]+=ans[i]/10;
            ans[i]%=10;
        }
    }
    if(ans[ans[0]+1]>0)ans[0]++;
}
int main(){
    int i=1;
    while(scanf("%s",a)!=EOF&&strcmp(a,"0")){
        fun();
    }
    for(int i=ans[0];i>0;--i)cout<<ans[i];
    putchar('\n');
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: