您的位置:首页 > 其它

Uva 401 Palindromes

2015-08-15 21:27 253 查看
Uva 401 Palindromes

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string “ABCDEDCBA” is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string “3AIAE” is a mirrored string because “A” and “I” are their own reverses, and “3” and “E” are each others’ reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string “ATOYOTA” is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, “A”, “T”, “O”, and “Y” are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
BNZ5
COO11
DP2S
E3Q3E
FR4
GS25Z
HHTT6
IIUU7
JLVV88
KWW9
LJXX
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter “0” is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
” – is not a palindrome.”if the string is not a palindrome and is not a mirrored string
” – is a regular palindrome.”if the string is a palindrome and is not a mirrored string
” – is a mirrored string.”if the string is not a palindrome and is a mirrored string
” – is a mirrored palindrome.”if the string is a palindrome and is a mirrored string
Note that the output line is to include the -’s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME

ISAPALINILAPASI

2A3MEAS

ATOYOTA

Sample Output

NOTAPALINDROME – is not a palindrome.

ISAPALINILAPASI – is a regular palindrome.

2A3MEAS – is a mirrored string.

ATOYOTA – is a mirrored palindrome.

字符串的处理问题

题目意思:

判断输入的字符串是否是回文串还是镜面字符串。

回文串:从左到右读和从右到左读是一样的。

镜面字符串:如果某个字符有镜面字符,转换为相应的镜面字符。转换后从左到右读和从右到左读是一样的。

数字0和字母O是等价的。

代码↓↓

[code]#include <iostream>
#include <cstdio>
#include <string.h>
#define N 5000
using namespace std;
char s1[40]="ABCDEHIJKLMNOPQRSTUVWXYZ123456789";
char s2[40]="A   3HIL JM O   2TUVWXY51SE4Z  8 ";
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    char a
;
    int len , i;
    bool flag1, flag2;
    while (~scanf("%s", a))
    {
        flag1 = flag2 = true;
        len = strlen(a);
        for (i = 0; i < len; i++)
        {
            if (a[i] != a[len - 1 - i])
            {
                flag1 = false;
                break;
            }
        }
        if (len == 1)
        {
            if (a[0] != rever(a[0]))
            {
                flag2 = false;
            }
        }
        for (i = 0; i < len && flag2; i++)
        {
            if (!strchr(s1, a[i]))
            {
                flag2 = false;
                break;
            }
            if (s2[strchr(s1,a[i]) - s1] != a[len - 1 - i])
            {
                flag2 = false;
                break;
            }
        }
        if (flag1 || flag2)
        {
            if (flag1 && flag2)
            {
                cout << a << " -- is a mirrored palindrome.\n";
            }
            else if (flag1)
            {
                cout << a << " -- is a regular palindrome.\n";
            }
            else
            {
                cout << a << " -- is a mirrored string.\n";
            }
        }
        else
        {
            cout << a << " -- is not a palindrome.\n";
        }
        cout << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: