您的位置:首页 > 大数据 > 人工智能

HDU 5172 pairs

2015-08-15 21:39 405 查看
HDU 5172 pairs

Problem Description

John has n points on the X axis, and their coordinates are (x[i],0),(i=0,1,2,…,n−1). He wants to know how many pairs<a,b> that |x−x[a]|≤k.(a<b)

[b]Input


The first line contains a single integer T (about 5), indicating the number of cases.

Each test case begins with two integers n,k(1≤n≤100000,1≤k≤109).

Next n lines contain an integer x[i] (−109≤x[i]≤109), means the X coordinates.

Output

For each case, output an integer means how many pairs<a,b> that |x−x[a]|≤k.

[b]Sample Input


2

5 5

-100

0

100

101

102

5 300

-100

0

100

101

102

Sample Output

3

10

题意:判断有多少数满足|x[b]−x[a]|≤k.(a<b)

注意:(1≤n≤100000,1≤k≤109).数据过多,暴力计算会TLE

首先对数组按升序排序

 用一个数组pos[i]记录x[i]右边最远的x[b]的b值,由于x[b]是单调递增的,所以找pos[i+1]时只要将b从pos[i]继续往右找即可。

另外答案结果非常大,应用long long来保存

[code]#include<cstdio>
#include <iostream>
#include<algorithm>
#include <string.h>
#define N 100200
using namespace std;
long a
, p
;

int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int T;
    long n, k, i, j;
    long long ans;
    cin >> T;
    while(T--)
    {
        ans = 0;
        memset(p, 0, sizeof(p));
        cin >> n >> k;
        for (i = 0; i < n; i++)
        {
            cin >> a[i];
        }
        sort(a, a+n);
        for(i = 0; i < n; i++)
        {
            if (i)
            {
                for(j = p[i - 1]; j <= n; j++)
                {
                    if ((j < n && a[j] > a[i] + k) || (j == n))
                    {
                        p[i] = j - 1;
                        ans += j - i - 1;
                        break;
                    }
                }
            }
            else
            {
                for (j = i + 1; j <= n; j++)
                {
                    if ((j < n && a[j] > a[i] + k) || (j == n))
                    {
                        p[i] = j - 1;
                        ans += j - i - 1;
                        break;
                    }
                }
            }
        }
        cout << ans << endl;
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: