您的位置:首页 > 其它

杭电 1285 确定比赛名次 【拓扑排序】

2015-08-14 17:33 369 查看

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17328 Accepted Submission(s): 6910



Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。





Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。





Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。





Sample Input
4 3
1 2
2 3
4 3






Sample Output
1 2 4 3



经典的拓扑排序~~~第一次写代码好激动哦~~



#include<stdio.h>
#include<string.h>
int map[550][550], indegree[550], queue[550];

void topo(int n){
	int i, j, tmp, t = 0;
	for(i = 1; i <= n; ++i){
		for(j = 1; j <= n; ++j){
			if(indegree[j] == 0){
				tmp = j;
				break;
			}
		}
		queue[t++] = tmp;
		indegree[tmp] = -1;
		for(j = 1; j <= n; ++j){
			if(map[tmp][j]) indegree[j]--;
		}
	}
	for(i = 0; i < n; ++i){
		printf("%d",queue[i]);
		if(i < n - 1) printf(" ");
	}
	printf("\n");
}

int main(){
	int n, m;
	while(~scanf("%d%d", &n, &m)){
		int i, a, b;
		memset(map, 0, sizeof(map));
		memset(indegree, 0, sizeof(indegree));
		for(i = 0; i < m; ++i){
			scanf("%d%d", &a, &b);
			if(map[a][b] == 0){
				map[a][b] = 1;
				indegree[b]++;
			}
		}
		topo(n);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: