您的位置:首页 > 其它

HDU 4324 Triangle LOVE

2015-08-14 17:30 429 查看

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 3542 Accepted Submission(s): 1381



[align=left]Problem Description[/align]
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!

Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.

Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.

[align=left]Input[/align]
The first line contains a single integer t (1 <= t <= 15), the number of test cases.

For each case, the first line contains one integer N (0 < N <= 2000).

In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.

It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).

[align=left]Output[/align]
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.

Take the sample output for more details.

[align=left]Sample Input[/align]

2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110


[align=left]Sample Output[/align]

Case #1: Yes
Case #2: No


[align=left]Author[/align]
BJTU

[align=left]Source[/align]
2012 Multi-University Training Contest 3

[align=left]Recommend[/align]
zhoujiaqi2010 | We have carefully selected several similar problems for you: 1068 4320 4325 3309 3712
//这道题就是用拓扑的方法来判断是否成环,我的做法就是看是否能够排成有序的序列,参考代码如下:

#include<stdio.h>
#include<string.h>
int indegree[10010];
char mp[10010][10010];
int main()
{  int  k=1;
int  flag;
int  t,n;
scanf("%d",&t);
while(t--)
{    int i,j;
//int m;
scanf("%d",&n);
memset(indegree,0,sizeof(indegree));
flag=0;
for(i=0;i<n;i++)
{
scanf("%s",mp[i]);
for(j=0;j<n;j++)
if(mp[i][j]=='1')
indegree[j]++;
}
//int  m;
for(j=0;j<n;j++)
{
for(i=0;i<n;i++)
if(indegree[i]==0)
break;

if(i==n)
{
flag=1;
break;
}
else
{
indegree[i]=-1;
for(int k=0;k<n;k++)
{
if(mp[i][k]=='1'&&indegree[k]!=0)
indegree[k]--;
}
}
}
if(flag)
printf("Case #%d: Yes\n",k++);
else
printf("Case #%d: No\n",k++);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: