您的位置:首页 > 其它

Agri-Net

2015-08-13 20:33 323 查看

Agri-Net

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 8 Accepted Submission(s) : 4
[align=left]Problem Description[/align]
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

[align=left]Input[/align]
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another.
Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this
problem.

[align=left]Output[/align]
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

[align=left]Sample Input[/align]

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0


[align=left]Sample Output[/align]

28


[align=left]Source[/align]
PKU

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0xfffffff
int map[505][505],mark[505];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int i,j,m;
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
scanf("%d",&m);
map[i][j]=map[j][i]=m;
}
int sum=0,flog;
memset(mark,0,sizeof(mark));
for(i=1;i<n;i++)
{
int min=INF;
for(j=2;j<=n;j++)
{
if(!mark[j]&&map[1][j]<min)
{
min=map[1][j];
flog=j;
}
}
sum+=map[1][flog];
mark[flog]=1;
for(j=2;j<=n;j++)
{
if(!mark[j]&&map[1][j]>map[flog][j])
map[1][j]=map[flog][j];
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: