您的位置:首页 > 其它

1028. List Sorting (25)

2015-08-11 09:37 323 查看
Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record
of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records
must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90


提交代码

——————————

比较简单

这里用到sort函数进行排序。

然后,全部用到cin的时候,会运行超时,换成scanf就可以了。

#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */
struct student{
int id;
string name;
int grade;
};
int n,c;

bool cmp_id(student a, student b){
return a.id<b.id;
}
bool cmp_name(student a, student b){
if(a.name!=b.name) return a.name<b.name;
else return a.id<b.id;
}
bool cmp_grade(student a, student b){
if(a.grade!=b.grade) return a.grade<b.grade;
else return a.id<b.id;
}
vector<student> v;
int main(int argc, char** argv) {

scanf("%d %d",&n,&c);

//v.resize(n);
for(int i=0; i<n; i++){
student s;
scanf("%d",&s.id);
cin>>s.name;
scanf("%d",&s.grade);
v.push_back(s);
}
if(c==1) sort(v.begin(),v.end(),cmp_id);
else if(c==2) sort(v.begin(),v.end(),cmp_name);
else sort(v.begin(),v.end(),cmp_grade);
for(int i=0; i<n; i++){
printf("%06d ",v[i].id);
cout<<v[i].name<<" ";
printf("%d\n",v[i].grade);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: