您的位置:首页 > 大数据 > 人工智能

Air Raid

2015-08-11 09:37 441 查看
Air Raid Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit Status Practice HDU 1151

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program
that finds the minimum number of paratroopers that can descend on the
town and visit all the intersections of this town in such a way that
more than one paratrooper visits no intersection. Each paratrooper lands
at an intersection and can visit other intersections following the town
streets. There are no restrictions about the starting intersection for
each paratrooper.

Input

Your program should read sets of data. The first line of the input file
contains the number of the data sets. Each data set specifies the
structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......

Sno_of_streets Eno_of_streets

The first line of each
data set contains a positive integer no_of_intersections (greater than 0
and less or equal to 120), which is the number of intersections in the
town. The second line contains a positive integer no_of_streets, which
is the number of streets in the town. The next no_of_streets lines, one
for each street in the town, are randomly ordered and represent the
town's streets. The line corresponding to street k (k <=
no_of_streets) consists of two positive integers, separated by one
blank: Sk (1 <= Sk <= no_of_intersections) - the number of the
intersection that is the start of the street, and Ek (1 <= Ek <=
no_of_intersections) - the number of the intersection that is the end of
the street. Intersections are represented by integers from 1 to
no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on standard output. For each input data
set the program prints on a single line, starting from the beginning of
the line, one integer: the minimum number of paratroopers required to
visit all the intersections in the town.

Sample Input

2

4

3

3 4

1 3

2 3

3

3

1 3

1 2

2 3

Sample Output

2

1

题意:单向路,最少伞兵可以路过所有点。

最小路径覆盖:在二分图中寻找一个尽量小的边集,使图中每一个点都是该边集中某条边的端点。

  最小路径覆盖 == 顶点数 - 最大匹配。

  证明:因为一条边最多可以包含两个顶点,所以我们选边的时候让这样的边尽量多,也就是说最大匹配的边集数目咯。剩下的点就只能一个边连上一个点到集合里啦。
http://www.cnblogs.com/alihenaixiao/p/4695298.html
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

#define N 1200

int n, m, vis
, maps

, used
;

int found(int u)
{
for(int i = 1; i <= n; i++)
{
if(maps[u][i] && !vis[i])
{
vis[i] = 1;
if(!used[i] || found(used[i]))
{
used[i] = u;
return true;
}
}
}
return false;
}

int main()
{
int t, x, y;

scanf("%d", &t);

while(t--)
{
memset(maps, 0, sizeof(maps));
memset(used, 0, sizeof(used));

scanf("%d%d", &n, &m);

while(m--)
{
scanf("%d%d", &x, &y);
maps[x][y] = 1;
}
int num = 0;
for(int i = 1; i <= n; i++)
{
memset(vis, 0, sizeof(vis));
if(found(i))
num++;
}
printf("%d\n", n-num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: