您的位置:首页 > 其它

hdu 1003

2015-08-10 20:57 316 查看
Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000). 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6


题意:
给你n个数a[1],a[2],a[3]...a
,要你求出最大连续子段和,并且输出这个和,和这个子段的起始位置和终止位置,如果这个子段有多种可能,输出第一种结果即可。
思路:
前段时间做个类似的题目,用的是暴力求解,用的两重循环,但是这个题目要求是n<100000,用两重循环肯定会超时,因此我们必须换一种思路,必须减少循环次数,当输入的时候,累计求和,用pos记录位置,star记录起点,end记录终点,如果sum小于0.就不必往下面累加了。
代码:
#include<cstdio>
using namespace std;
#define INF 0x7fffffff
int const maxn=100000+10;
int a[maxn];
int main()
{
int kcase=1;
int T,n,max,star,end,pos,sum;//max为最大字段和,star为枚举起始位置,end为枚举终止位置,sum为字段和,pos用来更新枚举起始位置
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
max=-INF;
pos=sum=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
if(sum>max)
{
max=sum;
star=pos;
end=i;

}
if(sum<0)
{
sum=0;
pos=i+1;

}
}
printf("Case %d:\n",kcase++);
printf("%d %d %d\n",max,star+1,end+1);//数组下标是从0开始的,而数的位置是从1开始的
if(T)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: