您的位置:首页 > 产品设计 > UI/UE

Advanced Fruits (LCS+递归、模板)

2015-08-10 20:56 525 查看

Advanced Fruits

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 5
Special Judge
[align=left]Problem Description[/align]
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit
emerges that tastes like a mixture between both of them.

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string
that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.

 

[align=left]Input[/align]
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. Input is terminated by end of file.

 

[align=left]Output[/align]
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

 

[align=left]Sample Input[/align]

apple peach
ananas banana
pear peach

 

[align=left]Sample Output[/align]

appleach
bananas
pearch
#include<stdio.h>
#include<string.h>
int a[1010][1010],p[1010][1010];
char s1[1010],s2[1010];
int l1,l2;
void lcs(int l1,int l2)
{
int i,j;
for(i=0;i<=l1;i++)
a[i][0]=0;
for(j=0;j<=l2;j++)
a[0][j]=-1;
for(i=1;i<=l1;i++)
for(j=1;j<=l2;j++)
{
if(s1[i-1]==s2[j-1])
{
a[i][j]=1;
p[i][j]=p[i-1][j-1]+1;
}
else
{
if(p[i-1][j]>=p[i][j-1])
{
p[i][j]=p[i-1][j];
a[i][j]=0;
}
else
{
p[i][j]=p[i][j-1];
a[i][j]=-1;
}
}
}
}
void print(int i,int j)
{
if(i==0&&j==0)
return ;
if(a[i][j]==1)
{
print(i-1,j-1);
printf("%c",s1[i-1]);
}
else if(a[i][j]==0)
{
print(i-1,j);
printf("%c",s1[i-1]);
}
else if(a[i][j]==-1)
{
print(i,j-1);
printf("%c",s2[j-1]);
}
}
int main(){
while(scanf("%s%s",s1,s2)!=EOF)
{
l1=strlen(s1);l2=strlen(s2);
memset(p,0,sizeof(p));
lcs(l1,l2);
print(l1,l2);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: