您的位置:首页 > 其它

HDOJ 1513 Palindrome (最长公共子序列 LCS)

2015-08-10 20:51 288 查看

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4062    Accepted Submission(s): 1384

[align=left]Problem Description[/align]
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted
into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

[align=left]Input[/align]
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from
'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

 

[align=left]Output[/align]
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

 

[align=left]Sample Input[/align]

5
Ab3bd

 

[align=left]Sample Output[/align]

2

注-此题为:HDOJ 1513 Palindrome

题意:

       倒转字符串,然后与原字符串求最长公共子序列,然后用长度减就行了

这个题目要求字符串为5000,所以二维数组肯定爆了,所以用滚动数组,用dp[2][M]

       滚动数组思想:滚动数组的作用在于优化空间,主要应用在递推或动态规划中(如01背包问题)。因为DP题目是一个自底向上的扩展过程,我们常常需要用到的是连续的解,前面的解往往可以舍去。所以用滚动数组优化是很有效的。利用滚动数组的话在N很大的情况下可以达到压缩存储的作用。

已AC代码:

#include<cstdio>
#include<cstring>
#define M 5050
#define max(x,y) (x>y?x:y)
char ch1[M],ch2[M];
int N;
int dp[2][M];  //滚动数组
void fz()                //倒转字符串
{
int i,j;
ch2
='\0';
for(i=0,j=N-1;i<N;++i,--j)
{
ch2[j]=ch1[i];
}
}
void CLS()    //LCS模板   ,数据过大,用滚动 数组
{
int i,j;
for(i=1;i<=N;++i)
{
for(j=1;j<=N;++j)
{
int x=i%2;   // 每次只要两行数据 ,将 i 变为 0 ,1
int y=1-x;
if(ch1[i-1]==ch2[j-1])
dp[x][j]=dp[y][j-1]+1;
else
dp[x][j]=max(dp[y][j],dp[x][j-1]);
}
}
}

int main()
{
int len;
while(scanf("%d",&N)!=EOF)
{
scanf("%s",ch1);
memset(dp,0,sizeof(dp));

fz();
CLS();

len=dp[N%2]
;
printf("%d\n",N-len);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息