您的位置:首页 > 产品设计 > UI/UE

poj1458 Common Subsequence【逆序打印】

2015-08-10 10:43 363 查看
Common Subsequence

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 43159Accepted: 17490
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly
increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X
and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output
4
2
0

嗯,一道模板题,LCS直接套,这里附带逆序打印,题目不需要,lcs运用动态规划思想,若当前s1[i]==s2[j]则dp[i][j]=dp[i-1][j-1]+1;若不相等则

dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s1[1010],s2[1010];
int dp[1010][1010];
int maxi(int x,int y)
{
return x>y?x:y;
}
int main()
{
int len1,len2,i,j;
while(~scanf("%s%s",s1,s2))
{
len1=strlen(s1);
len2=strlen(s2);
for(i=1;i<=len1;++i)
{
for(j=1;j<=len2;++j)
{
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=maxi(dp[i-1][j],dp[i][j-1]);
}
}
printf("%d\n",dp[len1][len2]);
/*      for(i=len1,j=len2;i>0&&j>0;)//逆序打印
{
if(s1[i-1]==s2[j-1])
{
printf("%c",s1[i-1]);
i--;
j--;
}
else
{
if(dp[i-1][j]>dp[i][j-1])
i--;
else
j--;
}
}
printf("\n");*/
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: