您的位置:首页 > 产品设计 > UI/UE

HDOJ--1159--Common Subsequence(lcs算法)

2015-08-10 10:38 441 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 28470 Accepted Submission(s): 12718



Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.



Sample Input
abcfbc abfcab
programming contest 
abcd mnp




Sample Output
4
2
0
题目大意:就是求最长公共子序列,比如第一组的最长子序列就是abfc,输出这个长度即可。给大家补充个常识哈:注意最长公共子串(Longest CommonSubstring)和最长公共子序列(LongestCommon Subsequence, LCS)的区别:子串(Substring)是串的一个连续的部分,子序列(Subsequence)则是从不改变序列的顺序,而从序列中去掉任意的元素而获得的新序列;更简略地说,前者(子串)的字符的位置必须连续,后者(子序列LCS)则不必。比如字符串acdfg同akdfc的最长公共子串为df,而他们的最长公共子序列是adf。
ac代码:
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
int dp[1010][1010];
int main(){
	char a[1010],b[1010];
	while(scanf("%s%s",&a,&b)!=EOF){
		int i,j;
		memset(dp,0,sizeof(dp));
		int len1=strlen(a);
		int len2=strlen(b);
		for(i=1;i<=len1;i++)
			for(j=1;j<=len2;j++){
				if(a[i-1]==b[j-1])
					dp[i][j]=dp[i-1][j-1]+1;
				else
					dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
			}
		printf("%d\n",dp[len1][len2]);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: