您的位置:首页 > 产品设计 > UI/UE

1458 Common Subsequence【lcs】

2015-08-10 10:41 471 查看
Common Subsequence

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 43175 Accepted: 17501
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find
the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output
4
2
0


单纯的考察 lcs 的题目

lcs,用的是动态规划的思想,具体暂时不太清楚,就是一直打表记录状态,等到最后的时候,记录下来的就是最长的那个序列....

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
int x[1005][1005];
int main()
{
char a[1005],b[1005];
while(~scanf("%s%s",a,b))
{
int i,j,lena=strlen(a),lenb=strlen(b);
memset(x,0,sizeof(x));
for(i=1;i<=lena;++i)//双循环打表记录状态
{
for(j=1;j<=lenb;++j)
{
if(a[i-1]==b[j-1])
{
x[i][j]=x[i-1][j-1]+1;
}
else
{
x[i][j]=max(x[i-1][j],x[i][j-1]);
}
}
}
printf("%d\n",x[lena][lenb]);//输出...
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: