您的位置:首页 > 其它

Hiking(vector+优先队列 实现贪心)

2015-08-07 13:09 363 查看
Link:http://acm.hdu.edu.cn/showproblem.php?pid=5360


Hiking

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 531 Accepted Submission(s): 284

Special Judge


Problem Description

There are n soda
conveniently labeled by 1,2,…,n.
beta, their best friends, wants to invite some soda to go hiking. The i-th
soda will go hiking if the total number of soda that go hiking except him is no less than li and
no larger than ri.
beta will follow the rules below to invite soda one by one:

1. he selects a soda not invited before;

2. he tells soda the number of soda who agree to go hiking by now;

3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than li and
no larger than ri,
otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.



Input

There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤105),
the number of soda. The second line constains n integers l1,l2,…,ln.
The third line constains n integers r1,r2,…,rn. (0≤li≤ri≤n)

It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.



Output

For each test case, output the maximum number of soda. Then in the second line output a permutation of 1,2,…,n denoting
the invitation order. If there are multiple solutions, print any of them.



Sample Input

4
8
4 1 3 2 2 1 0 3
5 3 6 4 2 1 7 6
8
3 3 2 0 5 0 3 6
4 5 2 7 7 6 7 6
8
2 2 3 3 3 0 0 2
7 4 3 6 3 2 2 5
8
5 6 5 3 3 1 2 4
6 7 7 6 5 4 3 5




Sample Output

7
1 7 6 5 2 4 3 8
8
4 6 3 1 2 5 8 7
7
3 6 7 1 5 2 8 4
0
1 2 3 4 5 6 7 8




Source

2015 Multi-University Training Contest 6



编程思想:每次模拟在当前已邀请的人数i中,对满足当前条件(li=<i<=ri)的各个区间先入队列,然后挑选这些区间中右区间最小的区间,然后删除该区间,并对在当前已邀请的人数+1后的情况下删除其他不满足条件的区间。即可以用优先队列存储满足条件的各个区间,然后每次维护一个满足当前条件的所有区间的队列。

AC code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#define LL long long 
#define MAXN 1000010
using namespace std;
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
int n;
int ans[MAXN];
struct node{
	int l;
	int r;
	int pos;
	bool operator < (const node &a) const 
	{
		return  a.r<r;//按右区间从小到大排序 
	}
}p[MAXN];
bool invited[MAXN];// invited[i]标记是否已被邀请 
vector<node>vec[MAXN];//vec[i]存储以左端点i为起点的各个区间 
int main()
{
	//freopen("D:\in.txt","r",stdin);
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<=n;i++)
		{
			vec[i].clear();
		}
		priority_queue<node>q;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&p[i].l);
		}
		for(i=1;i<=n;i++)
		{
			scanf("%d",&p[i].r);
			p[i].pos=i;
			vec[p[i].l].push_back(p[i]);
		}
		int fg=1;
		int cnt=0;
		memset(invited,false,sizeof(invited));
		for(i=0;i<=n;i++)
		{
			for(j=0;j<vec[i].size();j++)
			{
				q.push(vec[i][j]);
			}
			while(!q.empty()&&q.top().r<i)	q.pop();//删除其他不满足条件的区间
			if(q.empty())
			{
				fg=0;
				break;
			}
			node per=q.top();
			q.pop();
			invited[per.pos]=true;
			cnt++;
			ans[cnt]=per.pos;
		}
		printf("%d\n",cnt);
		if(cnt==0)
		{
			for(i=1;i<n;i++)
			{
				printf("%d ",i);
			}
			printf("%d\n",i);
		}
		else
		{
			for(i=1;i<cnt;i++)
			{
				printf("%d ",ans[i]);
			}
			printf("%d",ans[cnt]);
			for(i=1;i<=n;i++)
			{
				if(!invited[i])
					printf(" %d",i);
			}
			printf("\n");
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: