您的位置:首页 > 其它

hdu5375 Gray code(简单DP)

2015-08-12 13:10 183 查看
Link:http://acm.hdu.edu.cn/showproblem.php?pid=5375


Gray code

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 477 Accepted Submission(s): 281



Problem Description

The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical
switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.



Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code
is 1,you can get the point ai.

Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.



Input

The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)



Output

For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most



Sample Input

2
00?0
1 2 4 8
????
1 2 4 8




Sample Output

Case #1: 12
Case #2: 15
Hint https://en.wikipedia.org/wiki/Gray_code  http://baike.baidu.com/view/358724.htm




Source

2015 Multi-University Training Contest 7



官方题解:

##1007. Gray code

格雷码 题解 标准格雷码的性质:二进制a1 a2 ... an,对应的格雷码为a1 (a1 xor a2) ... (an-1 xor an) 题目就可以转为O(n)的dp dp[i][j]表示二进制第i位为j时前i位对应最大分数。

AC code:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#define LL long long 
#define MAXN 1000010
using namespace std;
const int INF=0x3f3f3f3f;
const int N=555;
int a[MAXN];
LL dp[200002][2];
LL ans;
int main()
{
	int t,i,j,cas;
	scanf("%d",&t);
	cas=0;
	while(t--)
	{
		cas++;
		char bin[200002];
		scanf("%s",bin+1);
		int len=strlen(bin+1);
		for(i=1;i<=len;i++)
		{
			scanf("%d",&a[i]);
		}
		if(bin[1]=='1'||bin[1]=='?')
		{
			dp[1][1]=a[1];
			dp[1][0]=0;
		}
		else
		{
			dp[1][0]=dp[1][1]=0;
		}
		for(i=2;i<=len;i++)
		{
			if(bin[i]=='?')
			{
				if(bin[i-1]=='0')
				{
					dp[i][0]=dp[i-1][0];
					dp[i][1]=dp[i-1][0]+a[i];
				}
				else if(bin[i-1]=='1')
				{
					dp[i][0]=dp[i-1][1]+a[i];
					dp[i][1]=dp[i-1][1];
				}
				else if(bin[i-1]=='?')
				{
					dp[i][0]=max(dp[i-1][0],dp[i-1][1]+a[i]);
					dp[i][1]=max(dp[i-1][0]+a[i],dp[i-1][1]);
				}
			}
			else if(bin[i]=='0')
			{
				if(bin[i-1]=='0')
				{
					dp[i][0]=dp[i-1][0];
					dp[i][1]=dp[i-1][1];
				}
				else if(bin[i-1]=='1')
				{
					dp[i][0]=dp[i-1][1]+a[i];
					dp[i][1]=dp[i-1][1];
				}
				else if(bin[i-1]=='?')
				{
					dp[i][0]=max(dp[i-1][0],dp[i-1][1]+a[i]);
					dp[i][1]=dp[i-1][1];
				}
			}
			else if(bin[i]=='1')
			{
				if(bin[i-1]=='0')
				{
					dp[i][0]=dp[i-1][0];
					dp[i][1]=dp[i-1][0]+a[i];
				}
				else if(bin[i-1]=='1')
				{
					dp[i][0]=dp[i-1][0];
					dp[i][1]=dp[i-1][1];
				}
				else if(bin[i-1]=='?')
				{
					dp[i][0]=dp[i-1][0];
					dp[i][1]=max(dp[i-1][0]+a[i],dp[i-1][1]);
				}
			}
		}
		ans=max(dp[len][0],dp[len][1]);
		printf("Case #%d: %lld\n",cas,ans);
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: