您的位置:首页 > 产品设计 > UI/UE

hdoj 1242 Rescue [BFS]

2015-08-06 22:39 393 查看


Rescue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21317 Accepted Submission(s): 7598



Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........


Sample Output

13


ps:可以试试 这组测试数据
1 3
r#a
输出应是 "Poor ANGEL has to stay in the prison all his life."

入门级广搜
#include<stdio.h>
#include<string.h>
#include<queue>
#define INF 0x3f3f3f
using namespace std;
const int maxn=210;
char map[maxn][maxn];
int visit[maxn][maxn];
struct node
{
int x,y,step;
friend bool operator < (node a,node b)
{
return  a.step > b.step;
}
};
int sx,sy,ex,ey;
int n,m;
int dir[4][2]={1,0,0,-1,0,1,-1,0};
void bfs(int sx,int sy,int ex,int ey)
{
int i,j,k,flag = 0;
node now,next;
now.x = sx;
now.y = sy;
now.step = 0;
priority_queue<node>q;
q.push(now);
while(!q.empty())
{
next = q.top();
q.pop();
if(next.x==ex && next.y==ey)
{
flag = 1;
break;
}
for(i = 0;i < 4;i++)
{
now.x = next.x + dir[i][0];
now.y = next.y + dir[i][1];
if(now.x>=0&&now.x<n &&now.y>=0 &&now.y<m && map[now.x][now.y]!='#')
{
if(map[now.x][now.y] == 'x')
now.step = next.step+2;
else
now.step = next.step+1;
if(  now.step >= visit[now.x][now.y] )	continue;
visit[now.x][now.y] = now.step;
q.push(now);
}
}

}
if(flag)
printf("%d\n",next.step);
else
printf("Poor ANGEL has to stay in the prison all his life.\n");
}

int main()
{
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(visit,INF,sizeof(visit));
for(i = 0;i < n;i++)
scanf("%s", &map[i]);
for(i = 0;i < n;i++)
for(j = 0;j < m;j++ )
{
if(map[i][j] == 'r')
{
sx = i;
sy = j;
}
if(map[i][j] == 'a')
{
ex = i;
ey = j;
}
}
bfs(sx,sy,ex,ey);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: