您的位置:首页 > 大数据 > 人工智能

C - We Love MOE Girls---(2015 summer training #9)

2015-08-05 14:35 513 查看
C - We Love MOE Girls
时限:500MS 内存:32768KB 64位IO格式:%I64d
& %I64u

问题描述

Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.

In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".

There are two situations:

If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.

Given an original sentence, what will it sound like aften spoken by Nanako?

输入

The first line has a number T (T <= 1000) , indicating the number of test cases.

For each test case, the only line contains a string s, which is the original sentence.

The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.

输出

For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.

样例输入

2
ohayougozaimasu
daijyoubudesu


样例输出

Case #1: ohayougozaimasunanodesu
Case #2: daijyoubunanodesu


分析:字符串小小的处理一下,水题。

CODE:

<span style="font-size:18px;">#include <iostream>
#include <string.h>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
int t,cas=0;
cin>>t;
while(t--){
cas++;
char c[105];
memset(c,0,sizeof(c));
cin>>c;
cout<<"Case #"<<cas<<": ";
int len=strlen(c);
if(len<4){
cout<<c;
}
else{
string s;
for(int i=len-4;i<len;i++)
s+=c[i];
if(s=="desu"){
for(int i=0;i<len-4;i++)
cout<<c[i];
s.erase();
}
else
cout<<c;
}
cout<<"nanodesu"<<endl;
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: