您的位置:首页 > 其它

Highways Poj

2015-08-03 16:32 381 查看
Highways

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 24872Accepted: 11468
Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways
so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1

3
0 990 692
990 0 179
692 179 0

Sample Output
692


题目输入的直接是两点间的距离。

用最小生成树求最大的距离。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define INF 0x3f3f3f3f

using namespace std;

int Map[2001][2001],ans,vis[2001],dis[2001],n,z,bj;
void Prim()
{
    int i,j,k,ma,pos;
    memset(vis,0,sizeof(vis));
    for(i=1;i<=n;i++)
    {
        dis[i]=Map[1][i];
    }
    vis[1]=1;
    for(i=1;i<n;i++)
    {
        ma=INF;
        for(j=1;j<=n;j++)
        {
            if(dis[j]<ma&&!vis[j])
            {
                ma=dis[j];
                pos=j;
            }
        }
        ans=ma>ans?ma:ans;//找到与根相连点的最小距离,再从这些最小距离中找到最大的距离
        vis[pos]=1;
        for(j=1;j<=n;j++)
        {
            if(dis[j]>Map[pos][j]&&!vis[j])
            {
                dis[j]=Map[pos][j];
            }
        }
    }
}
int main()
{
    int i,j,k,m,mi,cla;
    ios::sync_with_stdio(false);
    cin>>cla;
    while(cla--)
    {
        ans=0;
        cin>>n;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                cin>>Map[i][j];
            }
        }
        Prim();
    cout<<ans<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: