您的位置:首页 > 其它

Legal or Not

2015-08-03 16:31 239 查看
[align=left]Problem Description[/align]
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When
someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are
too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian
is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

[align=left]Input[/align]
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which
means x is y's master and y is x's prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

[align=left]Output[/align]
For each test case, print in one line the judgement of the messy relationship.

If it is legal, output "YES", otherwise "NO".
 

[align=left]Sample Input[/align]

3 2
0 1
1 2
2 2
0 1
1 0
0 0

 

[align=left]Sample Output[/align]

YES
NO

题解:裸的拓扑排序

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

bool map[1003][1003];
int indegree[1003];

bool topoSort(int n)
{
for(int i = 0;i < n;i++)      //对n个点进行判断
{
int k = -1;
for(int j = 0;j < n;j++)  //找到一个入度为0的点
{
if(indegree[j] == 0)
{
k = j;
indegree[j]--;
break;
}
}
if(-1 == k)      //没找到,不是
{
return false;
}
for(int j = 0;j < n;j++) //找到了之后,对该点的邻接边进行删除
{
if(map[k][j])
{
indegree[j]--;
}
}
}

return true;
}

int main()
{
int n,m;
while(scanf("%d%d",&n,&m) && (n + m) != 0)
{
int u,v;
memset(map,false,sizeof(map));
memset(indegree,0,sizeof(indegree));
for(int i = 0;i < m;i++)
{
scanf("%d%d",&u,&v);
if(!map[u][v])      //对于重边,只讨论一次,因为我们讨论的是先后次序关系,和边的多少无关
{
map[u][v] = true;
indegree[v]++;
}
}

if(topoSort(n))
{
printf("YES\n");
}
else
{
printf("NO\n");
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: