您的位置:首页 > 产品设计 > UI/UE

Poj 2299 Ultra-QuickSort (归排求逆序数)

2015-08-07 09:20 447 查看
Ultra-QuickSort

Time Limit: 7000MSMemory Limit: 65536K
Total Submissions: 48371Accepted: 17657
Description


In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence
elements until the sequence is sorted in ascending order. For the input sequence

9 1 0 5 4 ,

Ultra-QuickSort produces the output

0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤
a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0

Sample Output
6
0

因为没用long long 而WA。。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#define LL long long
#include<algorithm>
LL a[500010],b[500010],ans,n;
using namespace std;
void he(LL s,LL mid,LL e)
{
    LL i=s,j=mid+1,k=0;
    while(i<=mid&&j<=e)
    {
        if(a[i]>=a[j])//逆序数的生成只可能在a[i]>=a[j]的情况下,切有多少a[i]在a[j]前,就有多少逆序对<span id="transmark"></span>
        {
            ans+=(mid-i+1);
            b[k++]=a[j++];
        }
        else
        {
            b[k++]=a[i++];
        }
    }
    while(i<=mid)
    b[k++]=a[i++];
    while(j<=e)
    b[k++]=a[j++];
    for(i=s,k=0;i<=e;k++,i++)
            a[i]=b[k];
}
void mer(LL s,LL e)
{
    if(s<e)//分为两堆时,不可以有=,否则没意义。
    {
        LL mid=(s+e)/2;
        mer(s,mid);
        mer(mid+1,e);
        he(s,mid,e);
    }
}
int main()
{
    LL n,m,i,j,k,s;
    while(scanf("%lld",&n)!=EOF&&n)
    {
        ans=0;
        for(i=0;i<n;i++)
        {
            scanf("%lld",&a[i]);
        }
        mer(0,n-1);
        printf("%lld\n",ans);
    }
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: