您的位置:首页 > 其它

【HDU1712】【ACboy needs your help】

2015-08-03 09:10 155 查看


ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5155 Accepted Submission(s): 2786



Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?



Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.

Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].

N = 0 and M = 0 ends the input.



Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.



Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0




Sample Output

3
4
6




Source

HDU 2007-Spring Programming Contest



Recommend

lcy

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
  
int n,m;
int v[110][110];
int dp[110];
int main()
{
    while(scanf("%d%d",&n,&m),m+n)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				scanf("%d",&v[i][j]);
			}
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			for(int j=m;j>=1;j--)
			{
				for(int k=1;k<=j;k++)
				{
					dp[j] =max(dp[j],dp[j-k] + v[i][k]);
				}
			}
		}
		int ans = -1;
		for(int i=1;i<=m;i++)
		{
			ans = max(ans,dp[i]);
		}	
		printf("%d\n",ans);
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: