您的位置:首页 > 其它

UVALive 3708 Graveyard

2015-08-03 09:09 288 查看
Description



Programming contests became so popular in the year 2397 that the governor of New Earck -- the largest human-inhabited planet of the galaxy -- opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM
encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues
(besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose
the places for newcomers wisely!

Input
The input file contains several test cases, each of them consists of a a line that contains two integer numbers:
n -- the number of holographic statues initially located at the ACM, and
m -- the number of statues to be added
(2

n

1000,
1

m

1000)
. The length of the alley along the park perimeter is exactly 10 000 feet.

Output
For each test case, write to the output a line with a single real number -- the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.



Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

Sample Input

2 1
2 3
3 1
10 10


Sample Output
1666.6667
1000.0
1666.6667
0.0
【题目大意】
在一个圆上有些间隔相等的点,然后增加点,要求挪动原来的点依旧保证等距,问原来的点需要挪动的总距离。
【思路】
一开始WA是因为觉得所有点挪动的距离应该是一样长的。后来发现需要每一个都分开考虑。
#include <iostream>
#include<cstdio>
#include<cmath>

using namespace std;

int main()
{
int a, b;
double sum = 0, am, abm, mim, s;
while(scanf("%d%d", &a, &b) != EOF)
{
sum = 0; mim = 0; s = 0;
am = 1.0/a*10000;
abm = 1.0/(a+b)*10000;
for(int i=1; i<a; i++)
{
mim = fabs(am*i - abm);
for(int j=0; j<a+b; j++)
{
s = fabs(am*i - abm*j);
if(s<mim)
mim = s;
}
sum += mim;
}
printf("%.4lf\n", sum);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: