您的位置:首页 > 大数据 > 人工智能

N!Again

2015-08-02 18:38 399 查看
N!Again

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 24 Accepted Submission(s) : 10

Problem Description

WhereIsHeroFrom: Zty, what are you doing ?

Zty: I want to calculate N!……

WhereIsHeroFrom: So easy! How big N is ?

Zty: 1 <=N <=1000000000000000000000000000000000000000000000…

WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?

Zty: No. I haven’s finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!

Input

Each line will contain one integer N(0 <= N<=10^9). Process to end of file.

Output

For each case, output N! mod 2009

Sample Input

4

5

Sample Output

24

120

2009=7*7*41,所以41的阶乘及其以后的数字对2009求模值为零,另外需要注意的是,n!%2009与1%2009*2%2009·····n%2009的值是一样的,所以不必在意多求了几次对2009的模,另外还要注意0%2009=1。

#include<stdio.h>
int main()
{
    int i,n,ji[41];
    while(scanf("%d",&n)!=EOF)
    {
        if(n>=41)
        {
            printf("0\n");
            continue;
        }
        ji[0]=1;
        ji[1]=1;
        ji[2]=2;
        if(n>=3&&n<41)
        {
            for(i=3;i<41;i++)
            ji[i]=(ji[i-1]*i)%2009;
        }
        printf("%d\n",ji
);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: