您的位置:首页 > 产品设计 > UI/UE

【kmp】hdu1171 Number Sequence

2015-07-30 13:37 531 查看
                              Number Sequence

Time Limit: 5000MSMemory Limit: 32768KB64bit IO Format: %I64d & %I64u
Submit Status

Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output

6 -1

Source

HDU 2007-Spring Programming Contest

话说今天才学kmp,于是找了一道裸的kmp的题,写出来发现关于next数组的求解过程还是不太懂。。。居然是靠背的,看来需要多花时间去理解理解,不过好歹还是自己写出来的,放到这来存着吧。。

附一个大神关于kmp的一个超详细讲解,免得以后忘了

【代码】:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int T;
int a[1000000 + 5],b[10000 + 5];
int n,m;

void getnext(int *next)
{
int k = -1;
int j = 0;
next[0] = -1;
while(j < m)
{
if(k == -1 || b[j] == b[k])
{
j++;
k++;
if(b[j] != b[k]) next[j] = k;
else next[j] = next[k];
}
else k = next[k];
}
}
int kmp(int *next)
{
int i = 0,j = 0;
while(i < n && j < m)
{
if(j == -1 || a[i] == b[j])
{
i++;j++;
}
else j = next[j];
if(j == m)return i - j + 1;
}
return -1;
}
int main()
{
int next[10000 + 5];
scanf("%d", &T);
while(T--)
{
memset(next,0,sizeof(next));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%d%d", &n, &m);
for(int i = 0; i < n; i++)
scanf("%d", &a[i]);
for(int i = 0; i < m; i++)
scanf("%d", &b[i]);
getnext(next);
int ans = kmp(next);
printf("%d\n",ans);
}
return 0;
}


View Code
想吐槽一下,在oj上提交时,为毛找我的next数组的茬,我开的全局变量好么,一定要我开在main里面么,还非要我传参数

以下大神链接

点击打开链接
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: