您的位置:首页 > 其它

HDOJ1069 Monkey and Banana【dp】

2015-07-29 23:58 302 查看

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9435    Accepted Submission(s): 4900

[align=left]Problem Description[/align]
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey
is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 

[align=left]Input[/align]
The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

 

[align=left]Output[/align]
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

 

[align=left]Sample Input[/align]

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

 

[align=left]Sample Output[/align]

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342题意给出几种不同类型的长方体将它们按照垒在一起求所能垒成的最大高度(每种类型的长方体数量不限)假设每个类型长方体有六种不同形态按照矩形嵌套做
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[200];
struct Node{
int l;
int w;
int h;
}A[200];
int judge(int a,int b)
{
if(A[a].l<A[b].l&&A[a].h<A[b].h)
return true;
return false;
}
bool cmp(Node a,Node b)
{
if(a.l==b.l)return a.h<b.h;
return a.l<b.l;
}
int Max(int a,int b,int c)
{
if(a>=b&&a>=c)return a;
if(b>=a&&b>=c)return b;
if(c>=a&&c>=b)return c;
}
int main()
{
int n,i,j,a,b,c,t=1;
while(scanf("%d",&n),n)
{
int k=n;
for(i=0;i<n;++i)
{
scanf("%d%d%d",&a,&b,&c);//六种不同组合
A[i].l=a;A[i].h=b;A[i].w=c;
A[k].l=a;A[k].h=c;A[k].w=b;k++;
A[k].l=b;A[k].h=a;A[k].w=c;k++;
A[k].l=b;A[k].h=c;A[k].w=a;k++;
A[k].l=c;A[k].h=a;A[k].w=b;k++;
A[k].l=c;A[k].h=b;A[k].w=a;k++;
}
stable_sort(A,A+k,cmp);
memset(dp,0,sizeof(dp));
int count=0;
for(i=0;i<k;++i)
{
dp[i]=A[i].w;
for(j=0;j<i;++j)
{
if(judge(j,i)&&dp[i]<dp[j]+A[i].w)
dp[i]=dp[j]+A[i].w;
}
count=count>dp[i]?count:dp[i];
}
printf("Case %d: maximum height = %d\n",t++,count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDOJ1069 Monkey and