您的位置:首页 > 其它

NYOJ269VF【dp】

2015-08-01 15:01 232 查看

VF

时间限制:1000 ms  |            内存限制:65535 KB

[align=center]难度:2[/align]

描述


Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he
do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the Nth VF
in the point S is an amount of integers from 1 to N that have the sum of digits S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with N = 109)
because Vasya himself won’t cope with the task. Can you solve the problem?


输入There are multiple test cases.

Integer S (1 ≤ S ≤ 81).
输出The milliard VF value in the point S.样例输入
1

样例输出
10


题意:求1-1000000000中各位数字和相加等于s的个数


#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int dp[11][95];
void dpdabiao()
{
int i,j,k;dp[10][1]=1;
for(i=1;i<=9;++i)
dp[1][i]=1;//只有一位数个数为一
for(i=2;i<=9;++i)//位数
{
for(j=1;j<=i*9;++j)//该位数能组成的和
{
for(k=0;k<=9&&k<=j;++k)
{
dp[i][j]+=dp[i-1][j-k];//要知道由i位数组成的和为j的数的个数即需要知道比i少一位且与j相差不超过9的个数通过再加一位均能到j
}
}
}
}
int main()
{
dpdabiao();
int s,i,j,sum;
while(scanf("%d",&s)!=EOF)
{
sum=0;

for(i=1;i<=10;++i)
{
sum+=dp[i][s];
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  NYOJ269VFdp