您的位置:首页 > 其它

NYOJ 757 期末考试(优先队列)

2015-07-28 16:48 169 查看

期末考试

时间限制:1000 ms  |  内存限制:65535 KB

难度:2
描述
马上就要考试了,小T有许多作业要做,而且每个老师都给出来了作业要交的期限,如果在规定的期限内没
交作业就会扣期末成绩的分数,假设完成每门功课需要一天的时间,你能帮助小T扣除的分数最小吗?
输入输入n,表示n门功课(n<2000),接下来n行,每行两个数a,b,分别表示交作业的最后期限,迟交扣除的分数。

(以文件结尾)输出输出扣除的最小分数。样例输入
3
3 10
3 5
3 1
3
1 6
3 2
1 3
7
1 3
4 2
6 1
4 7
2 6
4 5
3 4

样例输出
0
3
5


不解释的一道题

ac代码:

#include <stdio.h>
#include <algorithm>
#include <queue>
using namespace std;
struct node
{
int time,value;
}d[2005];
bool cmp(node x,node y)
{
if(x.time==y.time)
return x.value<y.value;
return x.time<y.time;
}
int main()
{
int n,sum;
priority_queue<int,vector<int>,greater<int> >s;
while(scanf("%d",&n)!=EOF)
{
while(!s.empty())
s.pop();
for(int i=0;i<n;i++)
scanf("%d %d",&d[i].time,&d[i].value);
sort(d,d+n,cmp);
sum=0;
for(int i=0;i<n;i++)
{
if(s.size()<d[i].time)
s.push(d[i].value);
else
{
int x=s.top();
if(x<d[i].value)//总是用价值最大的把价值最小的替换出来
{
s.pop();
s.push(d[i].value);
sum+=x;
}
else
sum+=d[i].value;
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: