您的位置:首页 > 产品设计 > UI/UE

hdoj 1005Number Sequence

2015-07-26 20:14 369 查看

/*Number Sequence

Problem Description

A number sequence is defined as follows

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).



Input

The input consists of multiple test cases. Each test case contains 3 integers A, B

and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000).

Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

5*/

<span style="font-size:18px;"># include<stdio.h>
main()
{
    int f[100];
 int a,b,i;
    int n;
 while(scanf("%d%d%d",&a,&b,&n),a,b,n)
 {
  f[0]=1;
  f[1]=1;
  for(i=2;i<48;i++)
  {
   f[i]=(a*f[i-1]+b*f[i-2])%7;
  }
  n=(n-1)%48;
  printf("%d\n",f
);
 }
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: