您的位置:首页 > 其它

最小生成树(模板 Kruskal)

2015-07-26 10:24 363 查看
Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5

代码如下:

# include<iostream>
# include<cstdio>
# include<cstring>
# include<algorithm>
using namespace std;
const int N=105;
const int INF=1<<30;
struct edge
{
int fr,to,w,nxt;
bool operator < (const edge &a) const {
return w<a.w;
}
};
int pre
,n,head
,cnt;
edge e[N*(N-1)+5];
void add(int fr,int to,int w)
{
e[cnt].fr=fr;
e[cnt].to=to;
e[cnt].w=w;
e[cnt].nxt=head[fr];
head[fr]=cnt++;
}
int fin(int x)
{
if(x==pre[x])
return x;
return pre[x]=fin(pre[x]);
}
void Kruskal()
{
for(int i=1;i<=n;++i)
pre[i]=i;
sort(e,e+cnt);
int ans=0;
for(int i=0;i<cnt;++i){
int u=fin(e[i].fr);
int v=fin(e[i].to);
if(u!=v){
ans+=e[i].w;
pre[u]=v;
}
}
printf("%d\n",ans);
}
int main()
{
int a,b,c;
while(scanf("%d",&n)&&n)
{
cnt=0;
int m=n*(n-1)/2;
memset(head,-1,sizeof(head));
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}
Kruskal();
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: