您的位置:首页 > 其它

UVA 201 Squares

2015-07-26 10:23 525 查看
Squares
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit Status Practice UVA
201

Appoint description:
System Crawler (2015-07-21)

Description





A children's board game consists of a square array of dots that contains lines connecting some of the pairs of adjacent dots. One part of the game requires that the players count the number of squares of certain
sizes that are formed by these lines. For example, in the figure shown below, there are 3 squares-2 of size 1 and 1 of size 2. (The ``size" of a square is the number of lines segments required to form a side.)



Your problem is to write a program that automates the process of counting all the possible squares.

Input

The input file represents a series of game boards. Each board consists of a description of a square array of n2 dots (where 2 <= n <= 9) and some interconnecting horizontal and vertical
lines. A record for a single board with n2 dots and m interconnecting lines is formatted as follows:

Line 1: 	n the number of dots in a single row or column of the array  Line 2: m the number of interconnecting lines  Each of the next m lines are of one of two types: H i j indicates a horizontal line in row i which connects  the dot in column j to the one to its right in column j + 1  or V i j indicates a vertical line in column i which connects  the dot in row j to the one below in row j + 1

Information for each line begins in column 1. The end of input is indicated by end-of-file. The first record of the sample input below represents the board of the square above.

Output

For each record, label the corresponding output with ``Problem #1", ``Problem #2", and so forth. Output for a record consists of the number of squares of each size on the board, from the smallest
to the largest. lf no squares of any size exist, your program should print an appropriate message indicating so. Separate output for successive input records by a line of asterisks between two blank lines, like in the sample below.

Sample Input

4
16
H 1 1
H 1 3
H 2 1
H 2 2
H 2 3
H 3 2
H 4 2
H 4 3
V 1 1
V 2 1
V 2 2
V 2 3
V 3 2
V 4 1
V 4 2
V 4 3
2
3
H 1 1
H 2 1
V 2 1


Sample Output

Problem #1

2 square (s) of size 1
1 square (s) of size 2

**********************************

Problem #2

No completed squares can be found.


每一点记录该点右边 下边是不是有线,用结构体来记录,然后就每一个点暴力搜索,每一点看看能否构成边长为1 . 2. 3...的
比较坑人的是输出格式,注意一下
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct point
{
    int x,y;
};
point locote[15][15];
int num[15];
int n,m;
void is_square(int x,int y)
{
    for(int i=0;i<n;i++)
    {
        if(locote[x][y+i].x && locote[x+i][y].y)
        {
            int flag=1;
            for(int j=0;j<=i;j++)
            {
                if(locote[x+j][y+i+1].y==0 || locote[x+i+1][y+j].x==0)
                {
                    flag=0;
                    break;
                }
            }
            if(flag) num[i+1]++;
        }
        else
            break;
    }
}
int main()
{
    int countn=0;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        char c;
        int a,b;
        memset(locote,0,sizeof(locote));
        memset(num,0,sizeof(num));
        getchar();
        while(m--)
        {
            scanf("%c%d%d",&c,&a,&b);
            if(c=='H')
                locote[a][b].x=1;
            if(c=='V')
                locote[b][a].y=1;
            getchar();

        }
        /*
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                cout<<locote[i][j].x<<" ";
            cout<<endl;
            for(int j=1;j<=n;j++)
                cout<<locote[i][j].y<<" ";
            cout<<endl;
        }
        */

        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(locote[i][j].x && locote[i][j].y )

                      is_square(i,j);

            }
        }
        int flag=1;
        if(countn) printf("\n**********************************\n\n");
        printf("Problem #%d\n\n",++countn);
        for(int i=1;i<=n;i++)
        {
            if(num[i])
            {
                printf("%d square (s) of size %d\n",num[i],i);
                flag=0;
            }
        }
        if(flag)
            printf("No completed squares can be found.\n");
     

    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: