您的位置:首页 > 其它

hdu杭电 2147 kiki's game

2015-07-25 23:07 302 查看
Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one
people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".

Sample Input
5 3
5 4
6 6
0 0


Sample Output
What a pity!
Wonderful!
Wonderful!


#include<stdio.h>
int main()
{
	int m,n;
	while(scanf("%d%d",&m,&n),m+n)
	{
		if(m%2==0||n%2==0) printf("Wonderful!\n");
		else printf("What a pity!\n");
	}
	return 0;
}

/*
我们把Win的地方标记成W,Lose的地方标记成L
W	W	W	W	W	W	W	W
L	W	L	W	L	W	L	W
W	W	W	W	W	W	W	W
L	W	L	W	L	W	L	W
W	W	W	W	W	W	W	W
L	W	L	W	L	W	L	W

我们可以找到规律,当m%2==0||n%2==0,就Win了
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: