您的位置:首页 > 其它

zoj2417 Lowest Bit

2015-07-25 23:00 232 查看
Lowest Bit

Time Limit: 2000MSMemory Limit: 65536KB64bit IO Format: %lld & %llu
Submit Status

Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input

26

88

0



Sample Output


2

8

Source
Zhejiang University Local Contest 2005

分析:
水题。
ac代码:
#include <iostream>

#include<cstdio>

using namespace std;

int lowest(int n)

{

int c=0,a;

while(n)

{

a=n%2;

if(!a)

c++;

else

break;

n/=2;

}

return 1<<c;

}

int main()

{

int n;

while(scanf("%d",&n)&&n)

printf("%d\n",lowest(n));

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: