您的位置:首页 > 大数据 > 人工智能

hdoj 2674 N!Again 【好题】

2015-07-25 12:47 465 查看

N!Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4008 Accepted Submission(s): 2152

Problem Description
WhereIsHeroFrom: Zty, what are you doing ?

Zty: I want to calculate N!......

WhereIsHeroFrom: So easy! How big N is ?

Zty: 1 <=N <=1000000000000000000000000000000000000000000000…

WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?

Zty: No. I haven's finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!



Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.



Output
For each case, output N! mod 2009



Sample Input
4 
5




Sample Output
24
120




因为2009 = 41 * 7 * 7,所以对于大于或者等于41的数,它的阶乘会到达2009,然后2009取余2009 = 0。。。

#include <cstdio>
#define LL long long
int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{
		if(n >= 41)
		{
			printf("0\n");
			continue;
		}
		LL ans = 1;
		for(int i = 1; i <= n; i++) ans = (ans * i) % 2009;
		printf("%lld\n", ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: