您的位置:首页 > 编程语言 > PHP开发

HDU-1092-A+B for Input-Output Practice (IV)(继续!)

2015-07-15 14:08 543 查看


A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 76182 Accepted Submission(s): 40771



Problem Description

Your task is to Calculate the sum of some integers.

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5
0


Sample Output

10
15


Author

lcy

Recommend

JGShining | We have carefully selected several similar problems for you: 1093 1094 1095 1096 1061

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int n,a,sum;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
sum=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a);
sum+=a;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: