您的位置:首页 > 大数据 > 人工智能

HDU 2124 Repair the Wall

2015-07-14 09:41 537 查看
Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is

a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.

The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired
perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

[align=left]Input[/align]
The problem contains many test cases, please process to the end of file( EOF ). Each test case contains two lines. In the first line, there are two integers L(0<l<1000000000) <="" div="" inch).="" (in="" 1×ai="" of="" size="" the=""
has="" block="" sup]="" i[sup]th[="" that="" means="" )="" ai(0<ai<1000000000="" integer="" integers.="" positive="" n="" are="" there="" line,="" second="" in="" above.="" mentioned="" which="" n(0<="N<600)" and="">

[align=left]Output[/align]
For each test case , print an integer which represents the minimal number of blocks are needed. If Kitty could not repair the wall, just print "impossible" instead.

[align=left]Sample Input[/align]

5 3
3 2 1
5 2
2 1


[align=left]Sample Output[/align]

2
impossible
填洞…………  很简单
#include <stdio.h>
#include <algorithm>
using namespace std;
int a[1000000];
int main()
{
__int64 m,n,sum;
int i;
while(~scanf("%I64d %I64d",&m,&n))
{
sum=0;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
}
if(m>sum)
{
printf("impossible\n");
continue;
}
sort(a,a+n);
for(sum=0,i--;i>=0;i--)
{

if(m)
{
sum++;
m-=a[i];
}
if(m<=0)
break;
}
printf("%I64d\n",sum);
}
return 33;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: