您的位置:首页 > 大数据 > 人工智能

hdu3555 - Bomb(2010 ACM-ICPC Multi-University Training Contest(12))数位dp

2015-06-17 10:29 519 查看

Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 9755 Accepted Submission(s): 3457



Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the
power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?



Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.



Output
For each test case, output an integer indicating the final points of the power.


Sample Input
3
1
50
500




Sample Output
0
1
15

HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.


思路:找出不好49的然后减掉,没有前导零

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn=100;

LL N;
LL dp[maxn][maxn];
int dig[maxn];
LL dfs(int cur,int s,int e,int z)
{
    if(cur<0)return 1;
    if(!e&&!z&&dp[cur][s]!=-1)return dp[cur][s];
    LL ans=0;
    int end=(e?dig[cur]:9);
    for(int i=0;i<=end;i++)
    {
        if(s&&i==9)continue;
        if(z&&!i)ans+=dfs(cur-1,0,e&&(i==end),1);
        else ans+=dfs(cur-1,i==4,e&&(i==end),0);
    }
    if(!e&&!z)dp[cur][s]=ans;
    return ans;
}
LL solve(LL n)
{
    memset(dp,-1,sizeof(dp));
    LL tmp=n;
    int len=0;
    while(n)
    {
        dig[len++]=n%10;
        n/=10;
    }
    return tmp-dfs(len-1,0,1,1);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d",&N);
        printf("%I64d\n",solve(N)-solve(0));
    }
    return 0;
}


也可以直接算,要开三维

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn=100;

LL N;
LL dp[maxn][2][maxn];
int dig[maxn];
LL dfs(int cur,int s,int e,int last)
{
    if(cur<0)return s;
    if(!e&&dp[cur][s][last]!=-1)
        return dp[cur][s][last];
    LL ans=0;
    int end=(e?dig[cur]:9);
    for(int i=0;i<=end;i++)
    {
        if(last==4&&i==9)
            ans+=dfs(cur-1,1,e&&(i==end),i);
        else ans+=dfs(cur-1,s,e&&(i==end),i);
    }
    if(!e)dp[cur][s][last]=ans;
    return ans;
}
LL solve(LL n)
{
    memset(dp,-1,sizeof(dp));
    LL tmp=n;
    int len=0;
    while(n)
    {
        dig[len++]=n%10;
        n/=10;
    }
    return dfs(len-1,0,1,0);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d",&N);
        printf("%I64d\n",solve(N)-solve(0));
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: