您的位置:首页 > 其它

ZOJ 1586 QS Network (最小生成树)

2015-06-02 21:27 330 查看
QS Network
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit Status Practice ZOJ 1586

Appoint description:
System Crawler (2015-05-31)

Description

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:



A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0

Sample Output

370

计算两点之间权值的时候把两个点的适配器的耗费都加上,不能最后在kruskal里选出两点权值最小的再来加上适配器的钱,因为加上之后可能就不是最小了。

#include <iostream>
#include <cstdio>
#include <string>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <cmath>
#include <ctime>
using    namespace    std;

const    int    SIZE = 1005;
int    N,M,NUM;
int    FATHER[SIZE],BOX[SIZE];
struct    Node
{
int    from,to,cost;
}G[SIZE * SIZE];

void    ini(void);
int    find_father(int);
void    unite(int,int);
bool    same(int,int);
bool    comp(const Node &,const Node &);
int    kruskal(void);
int    main(void)
{
int    t,cost;

scanf("%d",&t);
while(t --)
{
scanf("%d",&N);
ini();
for(int i = 1;i <= N;i ++)
scanf("%d",&BOX[i]);
for(int i = 1;i <= N;i ++)
for(int j = 1;j <= N;j ++)
{
scanf("%d",&cost);
if(i >= j)
continue;
G[NUM].from = i;
G[NUM].to = j;
G[NUM].cost = cost + BOX[i] + BOX[j];
NUM ++;
}
sort(G,G + NUM,comp);
printf("%d\n",kruskal());
}

}

void    ini(void)
{
NUM = 0;
for(int i = 1;i <= N;i ++)
FATHER[i] = i;
}

int    find_father(int n)
{
if(n == FATHER
)
return    n;
return    FATHER
= find_father(FATHER
);
}

void    unite(int x,int y)
{
x = find_father(x);
y = find_father(y);

if(x == y)
return    ;
FATHER[x] = y;
}

bool    same(int x,int y)
{
return    find_father(x) == find_father(y);
}

bool    comp(const Node & a,const Node & b)
{
return    a.cost < b.cost;
}

int    kruskal(void)
{
int    ans = 0,count = 0;

for(int i = 0;i < NUM;i ++)
if(!same(G[i].from,G[i].to))
{
unite(G[i].from,G[i].to);
ans += G[i].cost;
count ++;
if(count == N - 1)
break;
}
return    ans;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: