您的位置:首页 > Web前端

POJ 2492 A Bug's Life (并查集)

2015-05-28 20:14 507 查看
A Bug's Life

Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 30130Accepted: 9869
Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

判断两只虫子是否同性。


#include <iostream>
#include <cstdio>
#include <string>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <cmath>
#include <ctime>
using    namespace    std;

const    int    SIZE = 2005;
int    FATHER[SIZE],MARK[SIZE],RANK[SIZE];

void    ini(int);
int    get_father(int);
void    unite(int,int);
bool    same(int,int);

int    main(void)
{
int    t,n,m,x,y,count = 0;
bool    flag;

scanf("%d",&t);
while(t --)
{
count ++;
scanf("%d%d",&n,&m);
ini(n);
flag = false;
while(m --)
{
scanf("%d%d",&x,&y);
if(flag)
continue;
if(same(x,y))
flag = true;
if(!MARK[x] && !MARK[y])
{
MARK[x] = y;
MARK[y] = x;
}
else    if(!MARK[x])
{
MARK[x] = y;
unite(x,MARK[y]);
}
else    if(!MARK[y])
{
MARK[y] = x;
unite(y,MARK[x]);
}
else
{
unite(x,MARK[y]);
unite(y,MARK[x]);
}
}
printf("Scenario #%d:\n",count);
if(flag)
puts("Suspicious bugs found!");
else
puts("No suspicious bugs found!");
puts("");
}

return    0;
}

void    ini(int n)
{
for(int i = 1;i <= n;i ++)
{
MARK[i] = RANK[i] = 0;
FATHER[i] = i;
}
}

int    get_father(int n)
{
if(n == FATHER
)
return    n;
return    FATHER
= get_father(FATHER
);
}

void    unite(int x,int y)
{
x = get_father(x);
y = get_father(y);

if(x == y)
return    ;
if(RANK[x] < RANK[y])
FATHER[x] = y;
else
{
FATHER[y] = x;
if(RANK[x] == RANK[y])
RANK[x] ++;
}
}

bool    same(int x,int y)
{
return    get_father(x) == get_father(y);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: