您的位置:首页 > 其它

【解题报告】【浙大PAT】03-树1. List Leaves (25)

2015-03-31 20:12 441 查看


03-树1. List Leaves (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives
the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:
4 1 5


题意,先输入结点个数N,然后输入从0到N-1结点的左右儿子,最后按照层次遍历输出叶子结点。

代码如下:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

typedef struct
{
int lchild;
int rchild;
}bitree;

typedef struct
{
int front;
int rear;
int data[10];
}queue;

int main()
{
char l,r; //输入左右子树
bitree bt[10];
queue q;
int child[10]; //检测根结点
memset(child,0,sizeof(child));

int root,n,i,j;
scanf("%d",&n);
getchar();
for(i=0;i<n;i++)
{
scanf("%c %c",&l,&r); //输入第i个结点左右子树
getchar();

if(l=='-')
bt[i].lchild=-1;
else if(l>='0'&&l<='9')
{
bt[i].lchild=l-'0';
child[bt[i].lchild]++;
}

if(r=='-')
bt[i].rchild=-1;
else if(r>='0'&&r<='9')
{
bt[i].rchild=r-'0';
child[bt[i].rchild]++;
}
}

for(i=0;i<n;i++)
{
if(!child[i])
{
root=i; //找根结点
break;
}
}

q.front=q.rear=0;
i=0;
q.data[0]=root;
do{
if(bt[root].lchild!=-1)
{
q.data[++i]=bt[root].lchild;//左子树入队
q.rear++;
}
if(bt[root].rchild!=-1)
{
q.data[++i]=bt[root].rchild;//右子树入队
q.rear++;
}

if(bt[root].lchild==-1&&bt[root].rchild==-1)
{
printf("%d",root);
if(n>1)
printf(" ");
else
printf("\n");
}
root=q.data[++q.front];
}while(q.front<n-1);
if(n>1)
printf("%d\n",root);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: