您的位置:首页 > 其它

PAT 03-2. List Leaves (25)

2015-02-06 19:48 260 查看

03-2. List Leaves (25)

题目链接:http://www.patest.cn/contests/mooc-ds/03-2

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and
gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:
4 1 5


解题报告:

1、先建树,然后层序遍历(就是用队列来bfs)就可以了。

2、注意没有出现过的是根,用一个数组标记一下找到根。

#include <bits/stdc++.h>
using namespace std;
struct Node {
int lchild;
int rchild;
Node() {
lchild = -1;
rchild = -1;
}
};
Node node[20];
int n, flag = 0;
bool findroot[20];
char l, r;
queue<int> q;
void bfs(int i) {
q.push(i);
while(!q.empty()) {
int cur = q.front();
q.pop();
if(node[cur].lchild == -1 && node[cur].rchild == -1) {
if(flag == 0) {
printf("%d", cur);
flag = 1;
} else {
printf(" %d", cur);
}
}
if(node[cur].lchild != -1) {
q.push(node[cur].lchild);
}
if(node[cur].rchild != -1) {
q.push(node[cur].rchild);
}
}
printf("\n");
}
int main() {
memset(findroot, false, sizeof(findroot));
scanf("%d", &n);
getchar();
for (int i = 0; i < n; i ++) {
scanf("%c %c", &l, &r);
getchar();
if(isdigit(l)) {
node[i].lchild = l - '0';
findroot[node[i].lchild] = 1;
}
if(isdigit(r)) {
node[i].rchild = r - '0';
findroot[node[i].rchild] = 1;
}
}
for (int i = 0; i < n; i ++) {
if(findroot[i] == 0) {
bfs(i);
break;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: