您的位置:首页 > 其它

HDU 1241--Oil Deposits【DFS】

2015-03-30 16:36 399 查看

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15293 Accepted Submission(s): 8789



Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.



Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.



Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.



Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0




Sample Output
0
1
2
2




#include <cstdio>
#include <string>

int dir[][2]={-1,-1,-1,0,-1,1,0,-1,0,1,1,-1,1,0,1,1};
int n,m;
char map[110][110];

void dfs(int x,int y){
    map[x][y]='*';
    for(int i=0;i<8;++i){
        int fx=x+dir[i][0];
        int fy=y+dir[i][1];
        if(fx<0 || fx>=m || fy<0 || fy>=n)
            continue ;
        if(map[fx][fy]=='@')
            dfs(fx,fy);
    }
    return ;
}

int main (){
    int i,j;
    while(scanf("%d%d",&m,&n),m,n){
        getchar();
        for(i=0;i<m;++i)
            scanf("%s",map[i]);
        int ans=0;
        for(i=0;i<m;++i)
            for(j=0;j<n;++j)
                if(map[i][j]=='@'){
                    dfs(i,j);
                    ans++;
                }
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: