您的位置:首页 > 其它

HDU 1241 Oil Deposits(DFS模板题)

2016-02-12 01:59 519 查看
Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2


//Must so
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
#include<ctype.h>
#include<queue>
#include<vector>
#include<set>
#include<cstdio>
#include<cmath>
#define mem(a,x) memset(a,x,sizeof(a))
#define inf 1<<30
#define NN 1000006
using namespace std;
const double PI = acos(-1.0);
typedef long long LL;

/**********************************************************************
DFS模板题
找到一个‘@’,就把他周围的‘@’都算给它,标记一下
同类题还有UVA-572
**********************************************************************/
int row,cow;
char mp[111][111];
int dx[8] = {-1,-1,-1,0,0,1,1,1};
int dy[8] = {-1,0,1,-1,1,-1,0,1};
void dfs(int x,int y)
{
for (int i = 0;i < 8;i++)//8个方向搜索
{
int xx = x + dx[i];
int yy = y + dy[i];
if (xx >= 0&&yy >= 0&&xx < row&&yy < cow&&mp[xx][yy] == '@')
{
mp[xx][yy] = '*';//标记一下
dfs(xx,yy);
}
}
}
int main()
{
while (cin>>row>>cow)
{
if (row == 0&&cow == 0) break;
for (int i = 0;i < row;i++)
scanf("%s",mp[i]);
int ans = 0;
for (int i = 0;i < row;i++)
{
for (int j = 0;j < cow;j++)
{
if (mp[i][j] == '@')
{
ans ++;
mp[i][j] = '*';
dfs(i,j);
}
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: