您的位置:首页 > 其它

1020. Tree Traversals (25)

2015-03-15 13:47 232 查看
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers
in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:
4 1 6 3 5 7 2


根据后续和中序遍历建立二叉树,然后再进行层次遍历!

#include<iostream>
#include<vector>
#include<queue>
using namespace std;

struct Node
{
Node *lChild;
Node *rChild;
int val;
Node(){ lChild = NULL; rChild = NULL; val = 0; }
};

vector<int>vecPost, vecInorder,vecLevel;
queue<Node*>q;

int findRootPos(int start,int end,int pend)
{
int pos = 0;
for (int i = start; i <= end; ++i)
{
if (vecInorder[i] == vecPost[pend])
{
pos = i;
break;
}
}
return pos;
}

void createTree(int pstart,int pend,int istart,int iend,Node *&root)
{
if (istart > iend)
return;
int rootPos = findRootPos(istart,iend,pend);
root = new Node();
root->val = vecInorder[rootPos];
createTree(pstart,pstart+rootPos-istart-1,istart,rootPos-1,root->lChild);
createTree(pend-iend+rootPos,pend-1,rootPos+1,iend,root->rChild);
}

void levelOrder(Node *root)
{
if (!root)
return;
Node *n;
q.push(root);
while (!q.empty())
{
n = q.front();
q.pop();
vecLevel.push_back(n->val);
if (n->lChild)
{
q.push(n->lChild);
}
if (n->rChild)
{
q.push(n->rChild);
}
}
}

int main()
{
int num, value;
scanf("%d",&num);
Node *root = NULL;
for (int i = 0; i < num; ++i)
{
scanf("%d",&value);
vecPost.push_back(value);
}
for (int i = 0; i < num; ++i)
{
scanf("%d",&value);
vecInorder.push_back(value);
}
createTree(0,num-1,0,num-1,root);
levelOrder(root);
for (int i = 0; i < vecLevel.size()-1; ++i)
{
printf("%d ",vecLevel[i]);
}
if (!vecLevel.empty())
printf("%d",vecLevel[vecLevel.size()-1]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: