您的位置:首页 > 其它

1020. Tree Traversals (25) (重建二叉树)

2015-11-29 01:35 351 查看


1020. Tree Traversals (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers
in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:
4 1 6 3 5 7 2


提交代码

题意: 给出一棵树的后序遍历和中序遍历, 让你求出他的层序遍历

题解:可以这样,给每个节点加一个权重,假设它的权重为x,那么他左儿子的权重为2*x, 右儿子权重为2 * x + 1,那么我们在重建二叉树的时候可以使用一个优先队列,这样,最后一个个弹出,就是他的层序遍历了。

#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

typedef long long LL;
struct node{
int val;
LL weight;
bool operator<(const node & X) const{
return weight > X.weight;
}
};

priority_queue<node> q;
void rebuild(int* post, int* in, int len, LL weight) {
if (len <= 0) return ;
node tmp = {post[len - 1], weight};
q.push(tmp);

int idx = 0;
while (in[idx] != post[len - 1]) idx++;
rebuild(post, in, idx, weight * 2);
rebuild(post + idx, in + idx + 1, len - idx - 1, weight * 2 + 1);
}

int main() {
int n;
int post[50], in[50];
scanf("%d", &n);
for (int i = 0; i < n; ++i) scanf("%d", post + i);
for (int i = 0; i < n; ++i) scanf("%d", in + i);
rebuild(post, in, n, 1);

while (!q.empty()) {
printf("%d", q.top().val);
q.pop();
if (!q.empty()) putchar(' ');
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: