您的位置:首页 > 其它

1020. Tree Traversals (25)

2018-02-19 20:30 323 查看
1020. Tree Traversals (25)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7

2 3 1 5 7 6 4

1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

#include <iostream>
#include <queue>

using namespace std;

const int MaxN = 36;
int post[MaxN],in[MaxN];
int c = 0,n;

typedef struct tnode
{
int data;
struct tnode * lchild;
struct tnode * rchild;
}TNode;

TNode * CreateTree(int pl,int pr,int il,int ir)
{
if(pl > pr)return NULL;

TNode * root = new TNode;
root->data = post[pr];

int k = il;
while(k<=ir)
{
if(in[k] == post[pr])
break;
++k;
}

root->lchild = CreateTree(pl,pl+k-il-1,il,k-1);
root->rchild = CreateTree(pl+k-il,pr-1,k+1,ir);

return root;
}

void level(TNode * root)
{
if(!root)return;
queue<TNode *>que;
que.push(root);

while(que.size())
{
TNode *now = que.front();
que.pop();
cout << now->data;
++c;
if(c != n)cout << " ";
if(now->lchild)que.push(now->lchild);
if(now->rchild)que.push(now->rchild);

delete now;
}
}

int main()
{
#ifdef _Debug
freopen("data.txt","r+",stdin);
#endif

std::ios::sync_with_stdio(false);
cin >> n;
for(int i=0;i<n;++i)
cin >> post[i];
for(int i=0;i<n;++i)
cin >> in[i];
TNode * head = CreateTree(0,n-1,0,n-1);
level(head);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1020