您的位置:首页 > 其它

POJ 2241 The Tower of Babylon(dp)

2015-07-04 15:49 477 查看
The Tower of Babylon

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 2292Accepted: 1288
Description

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the
corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.
Input

The input will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

给你N个长方体的长宽高,问把它们叠起来最高为多少(上面的长方体的长和宽 必须 小于 下面的长和宽)

首先按长方体低的面积进行排序,面积最大的在最下面,dp记录下每个长方体放上去时的最高的高度

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <cmath>
const int N = 100;
using namespace std;
struct node
{
    int x,y,z;
    int area;
}q
;
int cmp(void const *a, void const *b)
{
  return (*(node *)b).area - (*(node *)a).area;
}
int main()
{
    int n;
    int ca=1;
    while(scanf("%d",&n),n)
    {
         int s=0;
         for(int i=0;i<n;i++)
         {
             int x,y,z;
             scanf("%d%d%d",&x,&y,&z);
             q[s].x=x; q[s].y=y; q[s].z=z;q[s++].area=x*y;
             q[s].x=x; q[s].y=z; q[s].z=y;q[s++].area=x*z;
             q[s].x=y; q[s].y=z; q[s].z=x;q[s++].area=z*y;
         }
         qsort(q,s,sizeof(q[0]),cmp);
         int dp
;
         dp[0]=q[0].z;               //最下面一层的高度
         for(int i=1;i<s;i++)        //遍历所有长方体
         {
             dp[i]=q[i].z;
             for(int j=0;j<i;j++)    //能放在哪一层上
              {
                 if(q[i].x < q[j].x && q[i].y < q[j].y)
                  dp[i]=max(dp[i],dp[j] + q[i].z);
                 else if(q[i].y < q[j].x && q[i].x < q[j].y)
                  dp[i]=max(dp[i],dp[j] + q[i].z);
              }
         }
         printf("Case %d: maximum height = ",ca++);
         int ans=-1;
         for(int i=0;i<s;i++)
             ans=max(ans,dp[i]);
         printf("%d\n",ans);
    }
    return 0;

}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: