您的位置:首页 > 编程语言 > Java开发

03-树2. List Leaves (25) Java

2015-04-18 18:54 387 查看


03-树2. List Leaves (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives
the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8

1 -

- -

0 -

2 7

- -

- -

5 -

4 6

Sample Output:

4 1 5

解:

import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

class Node
{

int left=-1;
int right=-1;
public Node() {
super();
}
}

public class Main{

/**

*(方法说明)

*@param  无

*@return 无

*@throws 无

*/
public static void main(String[] args){

Node[] nodes = new Node[11];//节点
//n个节点
Scanner scanner = new Scanner(System.in);
int n= scanner.nextInt();
int child[] = new int[10];
int root = 0 ; //根
//构建树
for(int i=0;i<n;i++)
{
Node node = new Node();
char left = scanner.next().charAt(0);
char right = scanner.next().charAt(0);

if(!(left=='-'))
{
node.left=left-'0';
child[left-'0']++;
}
if(!(right=='-'))
{
node.right=right-'0';
child[right-'0']++;
}
nodes[i] = node;
}

//寻找根
for(int i=0;i<n;i++)
{
if(child[i]==0)
{
root = i;
break;
}
}

Queue<Integer> queue = new LinkedList<Integer>();
boolean firstPrintNode = true;
queue.offer(root);
while(!queue.isEmpty())
{
int currenNode = queue.poll();
//	System.out.print("currenNode:"+currenNode);
if(nodes[currenNode].left==-1 && nodes[currenNode].right==-1)
{
if(firstPrintNode)
{
System.out.print(currenNode);
firstPrintNode=false;
}
else
System.out.print(" "+currenNode);
}
if(nodes[currenNode].left!=-1)
{

queue.offer(nodes[currenNode].left);
}
if(nodes[currenNode].right!=-1)
{
queue.offer(nodes[currenNode].right);
}
}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: