您的位置:首页 > 大数据 > 人工智能

杭电-2057 A + B Again

2015-02-04 21:43 253 查看
Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.

Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.

Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.

Each case consists of two hexadecimal integers A and B in a line seperated by a blank.

The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA


Sample Output
0
2C
11
-2C
-90


#include<stdio.h>
int main()
{
	long long a,b;
	
	while(~scanf("%I64X %I64X",&a,&b))
	{
		b+=a;
		if(b<0)
		{
			printf("-");
			b=-b;
		}
		printf("%I64X\n",b);
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: